Some users unable to access boards
Incident Report for waffle.io
Resolved
This incident has been resolved.
Posted 8 months ago. Apr 10, 2018 - 22:45 UTC
Investigating
We are currently investigating this issue.
Posted 8 months ago. Apr 10, 2018 - 16:42 UTC