Some user's boards are not loading
Incident Report for waffle.io
Resolved
This incident has been resolved.
Posted 9 months ago. Mar 23, 2018 - 19:21 UTC
Investigating
We are currently investigating this issue.
Posted 9 months ago. Mar 23, 2018 - 18:07 UTC