Degraded performance
Incident Report for waffle.io
Resolved
This incident has been resolved.
Posted over 2 years ago. May 30, 2016 - 18:56 UTC
Investigating
We are currently investigating this issue.
Posted over 2 years ago. May 30, 2016 - 18:00 UTC