Degraded performance: Application not responsive for some users
Incident Report for waffle.io
Resolved
This incident has been resolved.
Posted 11 months ago. Nov 21, 2017 - 19:11 UTC
Investigating
We are currently investigating this issue.
Posted 11 months ago. Nov 21, 2017 - 18:58 UTC